Packages Dependence


#1

Hi

I have a problem with cube. I am try of used the cartopy package. however it has a problem with the dependence the packages numpy.

attached error.

thank you so much


ValueError Traceback (most recent call last)
in ()
20 print(np.version.version)
21 import regionmask
—> 22 import cartopy.crs as ccrs
23 import cartopy.io.shapereader as shpreader

~/work/workspace/.PackagesPython/lib/python3.6/site-packages/cartopy/init.py in ()
105 # Commonly used sub-modules. Imported here to provide end-user
106 # convenience.
–> 107 import cartopy.crs
108 import cartopy.feature # noqa: F401 (flake8 = unused import)

~/work/workspace/.PackagesPython/lib/python3.6/site-packages/cartopy/crs.py in ()
34 import six
35
—> 36 from cartopy._crs import CRS, Geodetic, Globe, PROJ4_VERSION
37 from cartopy._crs import Geocentric # noqa: F401 (flake8 = unused import)
38 import cartopy.trace

init.pxd in init cartopy._crs()

ValueError: numpy.ufunc size changed, may indicate binary incompatibility. Expected 216 from C header, got 192 from PyObject